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Notice and Disclaimer 

This manual’s sole purpose is to assist installers and/or users in the safe and 
efficient installation and usage of the system and/or product, and/or software 
described herein. 

BEFORE ATTEMPTING TO INSTALL AND/OR USE THE SYSTEM, THE INSTALLER AND THE 

USER MUST READ THIS MANUAL AND BECOME FAMILIAR WITH ALL SAFETY 

REQUIREMENTS AND OPERATING PROCEDURES. 

 The system must not be used for purposes other than those for which it 
was designed. 

 The use of the software associated with the system and/or product, if 
applicable, is subject to the terms of the license provided as part of the 
purchase documents. 

 ROSSLARE exclusive warranty and liability is limited to the warranty and 
liability statement provided in an appendix at the end of this document. 

 This manual describes the maximum configuration of the system with the 
maximum number of functions, including future options. Therefore, not all 
functions described in this manual may be available in the specific system 
and/or product configuration you purchased. 

 Incorrect operation or installation, or failure of the user to effectively 
maintain the system, relieves the manufacturer (and seller) from all or any 
responsibility for consequent noncompliance, damage, or injury. 

 The text, images and graphics contained in the manual are for the purpose 
of illustration and reference only. 

 All data contained herein is subject to change without prior notice. 

 In no event shall manufacturer be liable for any special, direct, indirect, 
incidental, consequential, exemplary or punitive damages (including, 
without limitation, any and all damages from business interruption, loss of 
profits or revenue, cost of capital or loss of use of any property or capital or 
injury). 

 All graphics in this manual are for reference only, some deviation between 
the image(s) and the actual product may occur. 

 All wiring diagrams are intended for reference only, the photograph or 
graphic of the PCB(s) are intended for clearer illustration and 
understanding of the product and may differ from the actual PCB(s).
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1. Installation 
1.1 PC Requirements 

The following are the recommended minimum PC requirements, 
needed for the AS-015 software to run efficiently: 

 Operating system: Windows 95/98/2000/NT/XP (English Version) 

 Processor: Pentium 133 MHz minimum 

 Memory: 16 MB minimum 

 A free COM port 

 RS-232 cable 

 Recommended: Network or local printer for printing function 

1.2 Connecting the AC-015 to your PC 

Connecting the PC software to the AC-015 requires the use of a serial 
cable connection between the AC-015 and the PC. 

To connect the AC-015 to a PC: 

1. Ensure that you turn off your PC’s power. 

2. Ensure that there is one free 9-pin serial (COM) port available. 

3. Take the RS-232 cable and cut off the connector from the side 
that does not connect to the PC (usually the male side). 

4. Remove approximately 7 cm (3”) of cable shielding and strip 
about 5 mm (¼”) off the ends of the wires to expose them. 

5. Using the modified RS-232 cable, attach the RS-232 connector to 
a vacant Serial (COM) port on the PC. 

6. Connect the wires to the corresponding terminals, labeled RS-
232, according to Figure 1. 
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Figure 1: Connecting the AC-015 to a PC 
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1.3 Software Installation Procedure 

To install the AS-015 software: 

1. Insert the CD into the CD-ROM drive and open the drive window. 

2. Double-click the  icon of the AS-015 application file. The 
following screen is displayed: 
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3. The system extracts the required files and then displays the 
following screen: 

 
4. Click Next. The Choose Destination Location screen opens. 

 
5. Select the required file storage location by clicking the Browse 

button or click Next to use the default destination. 



Installation  

AC-015 Software Manual 11 

6. Enter a new Program Folder name or accept the default name 
and click Next to continue. The Select Program Folder screen 
opens. 

 
7. Click Next. The Start Copying Files screen opens. 
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8. Click Next. The progress bar shows the percentage of installed 
files (this may take approximately 1 minute) until the Wizard 
Complete screen opens. 

 
9. Click Finish. 
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2. Getting Started 
2.1 Overview 

The AC-015 programmer is a controller that allows you to add or 
delete employees from the system, change system mode status, and 
change system authorization codes. 

The AC-015 provides a higher level of security as the programmer is 
normally placed in a secure location while the reader sensor is 
remotely located outside the premises to be controlled. Should the 
remote sensor be attacked, entry cannot be gained as the remote 
sensor only provides data to the programmer, not authorization to 
release the controlled door. 

The system may be connected with the optional PC monitor program 
for easier management of the employees’ database or for online 
monitoring of door access. The system is linked to a PC via an RS-232 
serial link. The PC receives information from the AC-015 that is 
displayed and saved to a database. Code entries and their 
consequences are visible in Online mode of the software. The 
Employees menu is used to describe, enter, and associate employee 
code numbers with employee names and details. The Programming 
menu is used to define door details, working days, and holidays. The 
Reports menu specifies which kind of report to build. 

The Options menu is used for communication setup, language setup, 
operators’ password setup, and database status. For more details, 
refer to the AC-015 Hardware Installation and Programming Manual. 

The AC-015 accepts up to 500 employees via the use of proximity 
cards (provided separately) or entering PIN codes into the system. 
Each employee is issued a unique proximity card or PIN code. 

Employees designated 01 to 10 are Master users and can operate the 
system in both the Normal and Secure modes of operation. 
Employees 11 to 500, when entered from the external reader sensor, 
may only operate the system in either Normal or Bypass modes. 
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It is very important to keep an accurate record of the slot number and 
its assignment to each employee. This is to help you add additional 
employees at a later time or delete a proximity or PIN code if one is 
lost or stolen. A record form is enclosed for your reference to assist 
you with your record keeping. 

The AC-015 is capable of learning both PIN codes (keyboard based 
codes, 4-digit code) and proximity codes (received from proximity card 
reader). The system can be connected to up to two reader sensors. An 
external reader must be located outside the restricted area, and is 
mandatory. The second reader is for internal installation. Both readers 
may be proximity or PIN type readers. 

A PIN reader, connected to the indoor reader input, can perform all 
the operations usually done from the on-board keyboard (depending 
on the PIN reader model). A PIN reader connected to an external 
reader input will behave mostly the same but the access level is 
different on certain AC-015 status of operation. 

2.2 Running the Software 

Follow these steps to run the AS-015 software: 

1. On your desktop double-click on the  icon OR click on the 
menu path: Start>Programs>Rosslare>AC-015. After initiating 
the program, the PC loads all databases and the Login window 
opens. 

Figure 2: Login Window 

 
2. Enter in the access password. The default password is admin. 

3. Click OK. The Main screen is displayed. 
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2.3 Main Screen Layout 

The AS-015 software, allows the user to perform functions by using 
the drop-down menus and the Toolbar buttons. Some functions can 
only be accessed via the Menu Bar. 

Figure 3: Main Screen Layout 

 
2.3.1 Menu Bar 
The Menu Bar contains three menus: View, Tools and Help. 

2.3.1.1 View Menu 

 

Menu Bar 
Toolbar 
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Table 1 presents the commands available in the View menu: 
Table 1: View Menu Commands 

Commands Description 
On Line Displays the current log events (see Section  3.1) 

Employees Gives details about specified employees (see Section  3.2) 

Programming Allows the user to program door details, modes of 
operation and programming codes (see Chapter  4) 

Reports Accesses the various employees’ reports (see Chapter  5) 

Exit Exits the AS-015 software. 

2.3.1.2 Tools Menu 

 
Table 2 presents the command available in the Tools menu: 

Table 2: Tools Menu Command 

Commands Description 
Options Accesses the following options: Communication Setup, 

Language, Operators and Database Status (see Section  3.3) 

2.3.1.3 Help Menu 
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Table 3 presents the commands available in the Help menu. 
Table 3: Help Menu Commands 

Commands Description 
Contents Opens the AS-015 software online help 

Index Opens the index of the AS-015 software 
online help 

Technical Support Displays the Technical Support information 
for the AS-015 software 

About AC-015 Displays the AC-015 software version 
information 

2.3.2 Toolbar 
Figure 4: Toolbar 

 
The toolbar provides shortcuts for accessing the AS-015 commands. 
These commands can also be accessed via the Menu Bar. 

Table 4 summarizes the available options, which are explained in 
more detail in the subsequent chapters. 

Table 4: Toolbar Commands 

Icon Choose this to… 

 

Displays the online status of the AS-015 (see Section  3.1) 

 

Access the Employees List (see Section  3.2) 

 

Program the Door name, Working Days and Holidays (see 
Chapter  4) 

 

Display the Reports options (see Chapter  5) 
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Icon Choose this to… 

 

Display the AS-015 software on line help 

 

Exit the AS-015 software 
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3. Using the AS-015 Software 
3.1 On Line 

The On Line window is opened by selecting View>On Line from the 

Menu Bar or by clicking the  icon on the Toolbar. 
Figure 5: On-Line Window 

 
The Data Table shows details of connected door movements, such 
as: door action, date and time, employee name and In/Out 
reader/keyboard. 

The Picture Box shows the employee’s picture of the selected row. 

If the Door Status changes, the status and the icon’s color change 
accordingly (see Section  4.1). 

Toolbar 

Picture  
Box 

Door Status 

Data Table 
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Table 5 presents the commands available in the Toolbar. 

The following options are available from the Toolbar: 
Table 5: On Line Toolbar Commands 

Icon Choose this to… 

 
Print the data table 

 

Display the AS-015 software on line help 

 
Close the On Line Screen and return to the AS-015 software main 
window 

3.2 Employees 

The Employees List window gives details about specified employees 
and allows the user to add new employees to the list and maintain 
current employees in the list. 

Figure 6: Employees List Window 
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Table 6 presents the options available in the Employees List toolbar. 
Table 6: Employees List Toolbar Commands 

Icon Choose this to… 

 

Add a new employee (see Section  3.2.1) 

 
Delete the selected employee (see Section  3.2.2) 

 

Edit the selected employee (see Section  3.2.3) 

 
Print all the employees’ details 

 
Open the AS-015 software on line help 

 
Close the Employees List window and return to the AS-
015 software Main screen 

The Employee Table displays the following main employee details: 

 Access – Displays to which readers the employee has access ability 

 Employment# – Employee number on the PC software 

 Slot# – Employee number at the Access Control point 

3.2.1 Creating a New Employee 
Every time a door is accessed, the system can identify the person who 
has passed through. Each employee must therefore be “created” on 
the system. 

To create a new employee: 

1. From the Menu Bar select View>Employees or click on the  
icon. The Employees List window opens. 

2. Click New to display the Employee Details screen. 

3. Enter the required details (see Section  3.2.4). 
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3.2.2 Deleting an Employee 
To delete an employee from the database: 

1. From the Employees List Table select an employee to delete. 

2. Click the  icon to delete an employee. 

3. Click Yes to confirm the deletion. The employee is deleted from 
the database. 

3.2.3 Editing an Employee 
To edit an employee’s details: 

1. From the Employees List Table select an employee to edit. 

2. Click the  icon to open the Employee Details window: 

3. Enter the required details (see Section  3.2.4). 

3.2.4 Employee Details 
The Employee Details window contains all employee data, including 
four tabs, which contain all the required employee and company 
information and allow you to create new codes for each employee. 

Figure 7: Employees Details Window 
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Table 7 presents the options available in the Employees Details 
toolbar: 

Table 7: Employees Details Commands 

Icon Choose this to… 

 

Save current employee data 

 

Save all employees’ data 

 

Undo the last action performed 

 
Print current employee data 

 
Access the AS-015 software on line help 

 
Close the Employee Details and return to the Employees List 
window 

Table 8 presents the buttons available in the Employee Details 
window: 

Table 8: Employees Details Buttons 

Icon Choose this to… 

 
Move to first employee. 

 
Move to previous employee. 

 
Move to next employee. 

 
Move to last employee. 
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The following four tabs are available: 

3.2.4.1 Details Tab 

 
The Details tab contains fields for entering the following data: ID 
number, gender, family status, birthday, telephone numbers, address, 
and email. 
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3.2.4.2 Access Tab 

 
The Access tab contains fields for entering the following data: Access 
Code and Slot Number at the Access Control. You can add or delete a 
proximity card or PIN code. 

To add an access code: 

1. Click the Add Code button. The following message appears: 

 
2. Swipe the card over the reader or enter in a PIN code. Once the 

code is accepted, it is displayed in the slot number field. 

To delete an access code: 

1. Click the Delete Code button. 

2. Confirm that you want the code deleted. 
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3.2.4.3 Company Tab 

 
The Company tab contains fields for entering the following data: 
Position, employment date, position date, start time (the official 
working start time) and working hours (the official number of 
working hours). 

3.2.4.4 Picture Tab 

 
The Picture tab allows a picture of the employee to be added or 
deleted. 
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To add a picture: 

1. Click the Add Picture button. A standard browse dialog opens. 

2. Browse to the file you wish to and click Add. The picture is now 
displayed on the Picture Tab. 

To delete a picture: 

1. To delete a picture, click on the Delete button. 

3.3 Options 

The Options window is opened by selecting Tools > Options from 
the Menu Bar: 

Figure 8: Options Window 

 
Choose from the following options: Communication Setup, 
Language, Operators, and Database Status. 
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3.3.1 Selecting the Correct Serial (COM) Port 
The user is required to set the COM port setting, which correlates to 
the COM port used for the serial cable. 

To select the Serial (COM) port: 

1. Click the Communication Setup button. The system asks for a 
password. Only Engineer operators and above may access this 
setting. 

2. Enter a valid password and click OK. The Communication Setup 
window opens: 

Figure 9: Communication Setup Window 

 
3. From the Com Port dropdown, select the required COM port 

that matches the COM port on the PC to which the AC-015 is 
connected. 

4. Click OK to save the settings and then click Close to exit. The 
Login window opens: 
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5. Enter a password (Administrator level only) and click OK to exit. 

6. Click Close to exit the Options window. 

3.3.2 Language Selection 
Use this option to change the language of the program to any one of 
the supported languages. 

To change the language setting: 

1. Click the Language button. The Change Language window 
opens. 

Figure 10: Change Language Window 

 
2. Select the required language from the list and click OK to save 

the setting. 
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3.3.3 Operators 
Use this option to grant or deny operators access to the program’s 
features, and to change passwords and other settings. 

3.3.3.1 Setting Up Operators 

The AC-015 supports three types of system operators, each with their 
own access rights to various menus and options within them. This 
ensures that only certain individuals have access rights to change 
system settings. 

Table 9 presents the kinds of operators supported. 
Table 9: Operator Types 

Type Description Default Password 
Guard Access to On-line screen only secur 

Engineer Allowed to change only the COM 
setting 

engin 

Administrator Allowed to change all settings and to 
access all screens. 

admin 

3.3.3.2 Setting Up Operator Passwords 

To set up an operator password: 

1. Click the Operators button. The Operators window opens: 
Figure 11: Operators Window 
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2. Click the tab of the operator type you wish to setup; for example 
Guard. 

3. Click Password. The following dialogue box appears: 

 
4. Complete all three fields and click OK. 

3.3.4 Database Status 
Use this option to reduce the size of the database when needed, 
which improves performance by saving memory on your computer. 

To reduce the size of the database: 

1. Click the Database Status button. The Database window opens: 
Figure 12: Database Window 

 
2. Choose one of the following: 

a. To compact data, click Compact. The following message 
appears: 
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b. To cut down data, click Cut Down. The following message 

appears: 

 
3. Click OK and click Close. 

 



System Programming  

AC-015 Software Manual 33 

4. System Programming 
4.1 Door Programming 

The Programming window is opened by selecting View > 
Programming from the Menu Bar. 

Figure 13: Programming Window 

 
4.1.1 Door Tab 
To configure the Door tab:  

1. Enter in the company name. 

2. Enter in the door name. 

The Door Status field displays the current status of the door: 
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Table 10: Door Statuses 

Icon Description 

 

Unknown – the default status. If the door status is unknown or 
door is disconnected. 

 

Normal Mode – A Valid Lock Strike code (proximity card or PIN 
code) is required to gain entry. The Mode LED is green. 

 

Secure Mode – Employee Codes and Open Codes ½ entered 
through external reader sensor are locked out, unless they are 
Management (Master) codes. All other valid proximity/PIN codes 
entered from internal reader or local keyboard gain entry. The 
Mode LED is red. 

 

Bypass Mode – For Fail Secure operation (factory default) the 
door is locked, but pressing the bell button (* key) releases the 
Locking device. The Mode LED is orange. 

4.1.2 Working Days Tab 
The duration and start times for each day of the week can be 
programmed. 

To configure the Working Days tab:  

1. Click the Working Days tab. 
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2. In the Start Time field, enter the starting time for each workday. 

3. In the Working Hours field, enter the number of hours that 
constitute a workday. 

4.1.3 Programming Holidays 
Any calendar holidays may be programmed into the system. 

To configure the Holidays tab:  

1.  Click the Holidays tab. 

 
2. To add a holiday, click Add. The following window opens: 
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a. In the Date field, enter the date on which the holiday falls. 

b. In the Holiday Name field, enter the name of the holiday. 

c. Click OK. 

3. To delete a holiday, select it from the list and click Delete. A 
confirmation message appears. 
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5. Reports 
To access the Reports window, click the Reports icon or select 
View>Reports from the Menu Bar. The Reports window opens. 

Figure 14: Reports Window 

 
 

 

The Reports option allows the user to run reports according to type 
and sort them according to date and employees. 

The Reports window contains a toolbar and is divided into three 
sections. 

5.1 The Toolbar 

Table 11 presents the options available in the Reports toolbar: 
Table 11: Reports Toolbar Commands 

Icon Choose this to… 

 
Display the report results on the screen 

 

Save the report as text file 

 

Print the report 

Toolbar 

Report 
List 

Date Filter Employees 
Filter 
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Icon Choose this to… 

 

Access the AS-015 software on line help 

 

Close the Reports window and return to the AS-015 software main 
screen 

5.2 Report List 

Select a Report from the Report List. You may choose from the 
following reports: 

5.2.1 Online Report 

 
The On Line report displays the Online movement of the employees. 
In the sorting frame you can choose the sorting order. The report 
displays the following fields: 

 Name – Employee’s number, private and surname 

 Date – Date of the exit/entry 

 Time – Time of the exit/entry 

 In/Out – In or out of the building 

 PIN code or proximity card 

 Door Action – Whether the door was opened or not 
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5.2.2 Absence Report 

 
The Absence report presents the employees who were absent from 
work. 

In the sorting frame you can choose the sorting order. The report 
ignores holidays and Saturday if it is defined in the Programming 
form. 

The report displays the following fields: 

 Name – employee's number, last name and first name 

 Date – Date of the absence 

5.2.3 Working Hours Details Report 
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Displays the number of hours the employee worked and the time he 
entered and left the factory. You can limit the data by using the date 
filter or employees’ filter. 

The report displays the following fields: 

 Name – Employee’s number and name 

 Date – Date of the work day 

 In – Time entered the building 

 Out – Time Left the building 

 Sub Total – presents the sub total of each entry and exit 

5.2.4 Incomplete Hours Report 

 
This report presents the employees that worked fewer hours than 
they should have worked. The Official Working hours are defined in 
the Employee Details form. If this field is empty, the data is taken 
from the Doors Information form in the working hours field. 

The report displays the following fields: 

 Name – Employee’s number and name 

 Date – Date of the work day 

 Schedule hours – Official hours the employee should work 

 Actual hours – Number of hours the employee actually worked 
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 Missing hours – The difference between actual hours to schedule 
hours 

 Global hours – Total working hours that same day from the first 
time the employee arrived until the last time he left the building 

5.2.5 Late Arrival Report 

 
This report presents the employees who arrived late to work. 

In the sorting frame, you can choose the sorting order. The Official 
Start time of each employee is defined in the Employee Details form 
in the Programming frame. If this field is empty, the official start time 
is as defined in the Programming form. The default time is 08:00 AM, 
but it can be changed. 

The report displays the following fields: 

 Name – Employee’s number, last name and first name 

 Date – Date of late arrival 

 Start Schedule – Official start time 

 Start Actual – Time the employee actually arrived at work 

 Late – Number of hours/minutes late 



Reports 

42 AC-015 Software Manual 

5.2.6 Working Hours Total Report 

 
This report presents a summary of the Working Hours Details report. 
The report displays the following fields: 

 Name – Employee's number and name 

 Date – Date of the work day 

 Actual Hours – Presents the total hours worked that day 

 Global Hours – The time from first time in to last time out each 
day 

5.2.7 Unauthorized Report 
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The Unauthorized report presents employees who tried to enter but 
the door did not open for some reason, as well as unknown people 
who entered through the door. Employees filter is not enabled 
because this report includes all movements. In the sorting frame you 
can choose the sorting order. 

The report displays the following fields: 

 Date – Date of the work day 

 Time – Time of attempted unauthorized entry 

 Name – Employee’s number and name 

 Slot# – Slot number at access control 

 Code# – PIN code or proximity card 

 Door Action – If the door opened or not 

 Reason – The reason the door did not open 

5.3 Employees Filter 

The Employees Filter allows you to filter which employees are 
displayed in a particular report by choosing a range of employee 
numbers. 

In addition, the Select All Employees ( ) button fills 
employees filter with all employees (1–500), while the Remove All 

Employees button ( ) clears the employees filter. 

5.4 Date Filter 

The Date filter allows you to filter the report results by date (the 
default is to show from one week ago until the present day) in either 
ascending or descending order. 
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